设备型号:Cisco WS-C2960S-24TL-L、Huawei S5720S-28X-LI-AC
本文适用于同类型交换机。

参考文章:Cisco交换机端口聚合(EtherChannel)华为交换机LACP模式链路聚合配置

一、Cisco交换机

channel-group的mode有5中模式:
其中active、passive是LACP( IEEE802.3ad )协议,适用于大多数设备。
desirable、auto是PAgP思科的私有协议,适用于思科设备。
on是强制启用,我上联防火墙的以太网通道选的这个,具体没研究明白是什么意思。

1、配置access端口

interface Port-channel1
 switchport access vlan 100
 switchport mode access

interface range GigabitEthernet1/0/1-2
 switchport access vlan 100
 switchport mode access
 channel-group 1 mode active

2、配置Trunk端口

interface Port-channel2
 switchport trunk allowed vlan all
 switchport mode trunk

interface range GigabitEthernet1/0/3-4
 switchport trunk allowed vlan all
 switchport mode trunk
 channel-group 2 mode active

二、华为交换机

1、 配置access端口

interface Eth-Trunk0
 port default vlan 100
 mode lacp

interface GigabitEthernet0/0/1 to interface GigabitEthernet0/0/2
 eth-trunk 0

2、 配置Trunk端口

interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

interface GigabitEthernet0/0/3 to interface GigabitEthernet0/0/4
 eth-trunk 1